Как я могу определить зависимость между 2 версиями пакета?

В каталоге Debian/контроль файла, как я определяю зависимость в пакете между 2 версиями этого пакета?

Например: в Python 2.5 или выше, но ниже, чем в Python 2.7.

Зависит: Python (от$VERSION_STRING)

Что бы $VERSION_STRING быть?

+581
John James 9 окт. 2016 г., 2:29:38
27 ответов

была такая же проблема. В Ubuntu загружает приложения в алфавитном порядке, поэтому изменение имени в автозагрузки может решить вашу проблему. Надеюсь, это тебе поможет.

+981
m2n037 03 февр. '09 в 4:24

Я использую Ubuntu 11.04 и недавно установили титановый платформе Appcelerator Studio версия 1.7, когда я загрузить демо-проект запустить, я получаю сообщение об ошибке вроде этого

Не удается загрузить файл:/главная/dananjaya/.Титан/выполнения/Линукс/1.1.0/libkhost.Итак, ошибки: /дома/dananjaya/.Титан/выполнения/Линукс/1.1.0/libwebkittitanium-1.0.так.2: файл слишком короткий

Мне не хватает каких-то зависимостей здесь или это ошибка в приложении? Спасибо заранее.

+954
Tony Junkes 31 дек. 2013 г., 3:31:28

Амазонки Исправлена проблема. Он взял их развитие команды немного времени, но они сделали новый зритель обратная совместимость с 11.2 для Linux. Я написал им гадость написать об этом. Если бы это было бесплатно, то время не будет проблемой, но Amazon Prime-это дорогостоящая услуга, и они должны рассматривать его как таковой. Это раздражает, чтобы быть положить на заднее сиденье как пользователь Linux, и приятно видеть быстрое время отклика от такой компании.

+933
Ethan Lam 6 июл. 2015 г., 16:04:34

Это проблема ядра для песчаного/мост Айви, которая установлена сейчас в 12.04 (среди других вещей, фиксируется на песчаных/габариты). Я просто так случиться, чтобы иметь песчаного моста и имеют такую же черную проблему.

Это также происходит с NVIDIA карты с помощью HDMI, но для их решения был для обновления до последней версии драйвера Nvidia ППА. В случае с интегрированным видео нужно дождаться 12.04 выйдет.

Мои настройки:

В Ubuntu 11.10 (32-Разрядная)
Корпорация Intel DZ68DP
Процессор Intel сердечника i7 2600

+880
dan2002 11 апр. 2017 г., 21:41:21

Шрифты были наверняка установлены правильно, пишет журнал.

Ваша проблема, однако, вероятно, заключается не столько с тем, что шрифты не в списке, но с тем, что вы пытаетесь использовать чужие шрифты. Графический интерфейс терминала профиль диспетчере только позволяет выбрать фиксированную ширину или моноширинный шрифты по умолчанию. Это означает, что шрифт, который вы можете увидеть (если вы определенно хотите его на терминал) или нет msfonts доступны в Убунту будет Курьер новый.

Они также должны быть доступны в LibreOffice.

Там может быть способ, чтобы заставить не-моноширинный шрифт, который будет отображаться в терминале через изменение файлов профиля на выбор правильного шрифта, но это уныло, как моноширинных шрифтов предназначены для того, чтобы сделать текст-только форматирование (Ф.е. Чертежи в формате ASCII, символов, таблиц) можно.

+833
CollinB 15 сент. 2016 г., 6:06:53

Поэтому у меня были некоторые проблемы в последнее время установка обновления, потому что мой загрузочный раздел не осталось свободного пространства. Я сделал некоторые исследования, чтобы попытаться найти лучший способ расширить раздел, но после просмотра программы GParted, я не уверен, если это возможно для меня, чтобы сделать это без переформатирования все.

Поскольку я не могу размещать фотографии, вот небольшое описание того, что у меня на /dev/ПДД:

Раздел - Файловая Система - Точки Монтирования - Размер Используемых Флагов

на /dev/sda1, поскольку------в ext4--------------/загрузки---------94MB - 94MB загрузки

на /dev/sda2---расширенная---------------------- 465.67 ГБ

на /dev/sda5, поэтому-----в ext4------------/дома----465.67 ГБ - 66 гигабайт -

нераспределенные-1.02 МБ

В качестве отступления, мой / перегородка установлена на SSD часть гибридного привода.

Любые комментарии/предложения будут с благодарностью.

+807
dimabagow 28 мая 2019 г., 2:07:07

http://www.omgubuntu.co.uk/2012/07/how-to-install-ubuntus-new-web-apps-feature

+746
Kees de Bruin 16 дек. 2010 г., 12:16:16

На мой взгляд последние версии Ubuntu 12.04.1 или ЛТС, будет прекрасно работать на вашем ноутбуке, если у вас было как минимум 2 ГБ оперативной памяти. Подумайте об обновлении.

В то же время я хотел бы попробовать Xubuntu В или с Lubuntu.

Xubuntu является основанное на окне обновление Xfce менеджер, который легче, чем Гном/единство. Lubuntu-это основанный на окно рабочего стола LXDE менеджер и не легче, чем Xubuntu в. Смотрите эту ссылку для сравнения двух.

+735
user52796 16 июл. 2016 г., 13:13:29

Не experiened с Ubuntu. Настроить DHCP-сервер около года назад, но не помню команду, чтобы увидеть активные аренды.

+717
Manohar Reddy 16 янв. 2011 г., 4:44:23

Мой BIOS управляет моей скорости вентилятора, и я хочу сохранить его таким образом. У меня машина в моем подвале, где он обычно довольно прохладно, и пока машина не под высокой нагрузкой вентиляторы не должны работать вообще. В BIOS уже обрабатывает это просто замечательно.

Но если мои поклонники не работают, у меня нет возможности проверить их, чтобы убедиться, что они не сломаны. Поэтому я хочу сделать скрипт, который будет включать вентиляторы на полную мощность в течение нескольких секунд, а затем использовать LM-датчики контроля скорости вентилятора, и тогда я буду знать, что болельщики не сломаны.

Как я могу вручную включить вентиляторы на полную скорость? Я не хочу использовать fancontrol, потому что я не ищу чего-то, что продолжает работать и продолжает контролировать скорость вентилятора. Я просто хочу что-то "по старинке", что позволит включить их независимо от температуры.

Другой поток сказал:

Если вы действительно хотите сделать это самостоятельно, вы можете, вероятно, найти специальное устройство файлы по имени pwm1, pwm2и т. д. в файл/sys/класс/hwmon/*/устройство/. Вы можете кот их, чтобы получить текущее значение и написать число от 0 до 255, чтобы изменить скорость вентилятора.

Это было бы идеально, но это не похоже на работу. Fancontrol говорит, что мой процессор вентилятор /системы/устройства/платформы/it87.656/pwm3, но когда я установил, что до 255, это не влияет на скорость вентилятора вообще.

Кто-нибудь знает, как я могу вручную включить вентилятор из скрипта, независимо от температуры?

+669
L Narayana 1 мар. 2019 г., 6:48:11

По теме в Каире-

Босс с мини-режим Cardapio enter image description here

http://www.webupd8.org/2010/11/cardapio-menu-update-brings-docky.html

+574
alik 22 февр. 2018 г., 15:40:18

Попробуйте apt-получить-скачать-единственный источник Linux-образ-3.0.0-15-универсальный

Ядра в Ubuntu базы по хребтине, но не пронумерованы таким же образом.

+484
Carol Eskine 1 дек. 2011 г., 11:27:48

Так я пытаюсь установить Gyachi на мой имак G5 запущенный в Ubuntu 12.04.1, но я не могу показаться, чтобы найти пакет, который работает на PowerPC интерфейс. Я нашла некоторые для PowerPC предприятия для Linux.оборотов строится в интернете, но я понятия не имею, как их установить. Это Лин: http://rpmfind.net/linux/RPM/epel/5/ppc/gyachi-1.1.71-5.el5.ppc.html

Кто-нибудь знает, как установить, или это работа?

Есть ли альтернатива Skype, которая имеет аудио и видео для Ubuntu? В моих знаниях, Gyachi является единственным, что, по крайней мере, как аудио, так и видео для Yahoo.

+429
domingl 26 мая 2017 г., 6:54:04

В mini.iso не установить X-сервер.

Как минимум, вам нужно судо apt-получить установку для xorg

Какие именно пакеты вам нужны после этого будет зависеть от того, что был установлен при установке Кубунту.

Вам также может понадобиться судо apt-получить установку пакет xserver-xorg, с языка.

+343
MiltonThales 16 мар. 2016 г., 1:46:53

Создать файл (допустим: my_sql_commands.в SQL), содержащий ваши команды SQL, например:

Select имя_таблицы из user_tables и;
выход;

А затем:

для sqlplus логин/пароль@oracle_instance @my_sql_commands.в SQL

Вот и все!

+271
SeyyedMojtaba 24 дек. 2012 г., 7:53:18

Я пытаюсь установить раздвоенный-daapd, но я бы предпочла, чтобы я мог запустить его без растеризации шрифтов (точнее определить свою собственную службу и используемые вместо использования ДГУ в API).

Причина в том, что я хочу netatalk долю моего времени резервного копирования машина и доля Самба для символической поддержки связаться (netatalk не поддерживает симлинки). Эти две определяются как различным службам система. Чтобы сделать эту работу, мне придется отключить используемые ей ДГУ API, или еще netatalk, как правило, берут за все услуги (на OSX предпочитает АФП через SMB).

Если теперь я пытаюсь запустить раздвоился-daapd, он просто не. Раздвоенный-daapd требует используемые в ДГУ API, чтобы быть включен и работает. Есть ли какой-то способ обойти это ограничение, так что я могу вручную задать свою собственную службу даап в система.

Может, что-то вроде позволяет, но игнорируя dbus в система, или запускают дубликат демон используемые с другой конфигурационный файл?

+241
tlegutko 30 апр. 2013 г., 11:14:54

Имя пользователя может иметь только строчные буквы и цифры, и должны начинаться с буквы.

+234
Lee Lego 28 апр. 2015 г., 20:22:12

It asks to install plugin, while the Install button is unclickable.

Я использую Ubuntu 12.04 ЛТС 64бит. При попытке воспроизведения Midi (.файл середине), он просит плагин для GStreamer, но сама кнопка установки начинает периодически. На самом деле, я gstreamer0.10-плагинов-плохо (плагины для GStreamer для MMS, WavPack тому, в QuickTime, musepack выступает-без (для i386) в конце) уже установлен.

Как же нам решить эту проблему? Спасибо заранее.

+221
nealmcb 10 янв. 2014 г., 8:48:22

Потому что работа на этом еще не сделали (только некоторые). Полная поддержка будет в QML и Qt. Я думаю, что вы, вероятно, сможете использовать их в конце концов с другими языками. Была УДС (саммит разработчиков Ubuntu) сессии об этом. Чтобы получить лучшие ответы, было бы лучше, чтобы подписаться на список рассылки и задать там (просто отправить письмо к нему):

https://launchpad.net/~Убунту-телефон

+196
LoveSu4eK 24 окт. 2012 г., 14:10:15

Возможные Дубликаты:
Моя видеокарта ATI поддерживается в Ubuntu?

Я недавно вновь установленных Oneric на моем Dell ноутбука Vostro 1000. Я получил беспроводную работу (что не важно) и сейчас я работаю на видео конфиг. Видеокарта на ATI x1150 с сейчас вроде бы с помощью галлий 3д драйвер версии 0.3 я думаю, и работает очень хорошо, но я заметил, некоторая заторможенность в видео. Я просматривал некоторые другие сообщения о возможности использования fglrx от этой системы.

Жокей не обнаруживая своего ATI IGP и компания Xpress 1150

Можно ли установить старые версии катализатора через жокея?

но похоже, что ее либо не возможно, либо не рекомендуется, поэтому мой вопрос заключается в следующем. Может быть стоит мое время, чтобы попытаться установить говорят катализатор 9.2 (я считаю, что это последняя версия, официально поддерживающих мою карту) или я должен придерживаться галлий? Должен ли я палку с галлием, то есть там, где я могу получить информацию к нему, которые будут (надеюсь) исправить некоторые лаги? Будет обновление или xorg кромкообрезных ППА обновление? Спасибо, что нашли время, чтобы попытаться помочь.

+195
Ryan Calhoun 2 июл. 2018 г., 19:23:57

Возможные Дубликаты:
Будет финальная версия 12.04 использовать изменения управления питанием, нашли в ядро 3.3

Я спрашиваю как

https://wiki.ubuntu.com/PrecisePangolin/TechnicalOverview/Beta1#Ubuntu_Kernel

упоминает, они позволят ЛС6, который не совпадает с фиксации АСПМ вопрос.

http://www.phoronix.com/scan.php?page=news_item&px=MTAyMjk

+180
zbug 8 июн. 2013 г., 4:13:54

У меня Ubuntu 12.04.1 и NVIDIA для видеокарты GTX 560

"Дополнительные драйверы" в систему пустой!

Как я могу установить драйвер...?

Я должен скачать их с GeForce.com ?

Спасибо!

+151
Fyodor Sukhov 23 дек. 2011 г., 13:27:39

При загрузке мой компьютер, я вижу несколько записей в моем меню grub, такие как мемтест, различных версий Ubuntu, а также соответствующего возмещения. Что мемтест имею в виду и почему там много записей Убунту? Одно отличается от другого?

+119
Abdullah Aslam 16 апр. 2015 г., 15:18:39

Btrfs-это достаточно стабильный и вызвала у меня никаких проблем.

У людей очень сильно разнится личный риск допуски для файловых систем. для многих предприятий, ориентированных на syaadmins ТЭО должен доказать это самостоятельно в течение десяти лет, прежде чем благословил стабильными, а другие получают кайф от бега последние экспериментальные файловой системы кластера. Btrfs-это очень вряд ли потеряете ваши данные, хотя некоторые расширенные функции (например, создание RAID5/6) не работает. Некоторые люди, которые считают ее неустойчивой и рассматривать новые вещи, как в ext4 последнюю очередь.

+118
Michael H 5 мар. 2015 г., 20:41:21

Это странное поведение разрешений Linux, но разрешения на удаление файлов выдаются разрешения на каталог, а не файл.

Попробуйте это:

тест команды mkdir 
сенсорный тест/файл

# Сделать каталог РО
чмод а-ш тест

файл ls-l тест/
-РВ-РВ-Р-- 1 Бодхи Бодхи 0 2012-02-28 21:13 тест/файл

испытания РМ/файл
РМ: тест невозможно удалить `/' файл: отказано в доступе

Разрешение на запись. На обычный файл, это означает, что вы можете изменить файл, записать новые данные в файл ака. В случае каталога, разрешение записи означает, что вы можете добавить, удалить, и переименовать файлы в каталоге. Это означает, что если файл имеет разрешение записи бит, вы имеете право модифицировать содержимое файла, но вы позволили переименовать или удалить файл только в случае, если права доступа к файлу каталога позволит вам сделать это.

См http://www.tuxfiles.org/linuxhelp/filepermissions.html

Чтобы разрешить (РВ) доступ к файлу, но предотвратить удаление или переименование, установить липкий бит на директорию.

# изменения "тест" в свой каталог
тест команду chmod +Т 
сенсорный тест/файл
чмод тест+ж/файл

команда ls-l тест | грэп 
drwxrwxrwt 4 Бодхи Бодхи 4096 2012-03-07 17:тест 08 

файл ls-l тест | грэп 
-РВ-РВ-РВ - 1 Бодхи Бодхи 13 2012-03-07 17:10 файл 

# СУ на другого пользователя, "тест"
[email protected]:/home/bodhi$ эхо-это работает !!!' > тест - > /файл

тест [email protected]:/home/bodhi$ кот/файл
Это работает !!!

тест [email protected]:/home/bodhi$ РМ/файл
РМ: тест невозможно удалить `/файл': операция не допускается

http://www.techcuriosity.com/resources/linux/advanced_file_permissions_in_linux.php

Если липкий бит установлен для каталога, только владелец этого каталога или владелец файла может удалить или переименовать файл в этот каталог.

+113
Clayton Smith 29 дек. 2011 г., 6:02:40

она была выпущена в обычном репозитории для 11.04

для более старых версий, вот последний скачать страница

все, что вам нужно сделать, это извлечь файлы в папку и в настройках программы по умолчанию для запуска файл Firefox в этом каталоге

+50
Nick Pakhomov 18 июн. 2012 г., 18:38:33

Почему-то я был под впечатлением, что музыка, приобретенная от Ubuntu в одном магазине не влияют на мою квоту, но после того как я купил несколько альбомов, я вижу, что я имущими менее доступной памяти.

Куплена музыка должна рассчитывать против вашего Ubuntu одна квота облачное хранилище?

+14
Khetesh 28 нояб. 2011 г., 18:26:13

Показать вопросы с тегом